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Cash Drawer 

IP-5725 – Cash Drawer Support for J6412 Mainboard 

This function adds Cash Drawer support for the Idealpos i15 J6412. 

 

New POS Terminals supplied by Idealpos will be configured/supplied with the required executable so that the Cash 

Drawer will work. 

 

Go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Other Peripherals > Cash Drawer > 

Connection/2nd Drawer > J6412. 

 

 
  



 Update History 
Return to top 

Idealpos 8 Build 14 - Update History Page 3 of 26 

 

Digital Receipts  

IP-5646 – Support for Digital Receipts 

This function introduces the ability to utilise Digital Receipts with Idealpos. 

Digital Receipts in Idealpos were previously exclusive to the Slyp Integration.  

This change makes the Digital Receipt function available to venues that are utilising Idealpos Online/Idealpos Online 

Reporting. 

 

The Digital Receipt prompt outlined below will be triggered when each of the following conditions are met: 

 

• Yes/No Option “Prompt to Print Receipt” is enabled. 

• Receipt Printing is turned off 

• Digital Receipts (Email and/or SMS) enabled in Global Options 

• Idealpos Online/Idealpos Online Reporting module is in use (Digital Receipt Format must be configured in 

Idealpos Online) 

 

When this function is triggered (with both SMS and Email options enabled), the POS Screen will display the following 

options; one option can be used for each sale performed: 

• Text Receipt to – The receipt will be texted to the entered mobile phone number. 

• Email Receipt to – The receipt will be emailed to the entered email address. 

• Print – The receipt will be printed to the receipt printer. 

• No Thanks! – A receipt will not be issued to the customer. 

 

If a customer has been added to the transaction and the customer has a mobile phone number and/or an email 

address entered against their customer record, their Phone Number and/or Email Address will be automatically 

populated in the “Text Receipt to” and/or “Email Receipt to” options. 
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Before configuring this function, ensure that you have the Idealpos Online and/or Idealpos Online Reporting module. 

If the Idealpos Online Reporting module is not configured, this function will not work. 

 

To configure this function, go to: 

Back Office > Setup > Global Options > Sales. 

Within the Digital Receipts section, toggle the following checkboxes as required: 

Email – Enabling this option will trigger the Digital Receipt prompt to display the “Email receipt to” field so that 

receipts can be sent via email. 

SMS – Enabling this option will trigger the Digital Receipt prompt to display the “Text Receipt to” field so that receipts 

can be sent via SMS/text message. 
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Close the Global Options window, then go to: Back Office > Setup > Yes/No Options. 

Search: “prompt to print” 

Enable “Prompt to Print Receipt” 

 

 
 

Close the Yes/No Options window.  

A Receipt On/Off button must exist on the POS Screen so that receipts can be turned off to then enable the Digital 

Receipt prompt to appear. 

 

To create a Receipt On/Off button, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

Select the desired POS Screen tab to create the button in, then select a blank POS Screen button and configure as 

follows: 

Note that the Button Caption will not be shown on the button but instead, pressing the button will trigger the caption 

to toggle between “RECEIPT IS OFF” and “RECEIPT IS ON”. 

 

 
 
Once configured, close the POS Screen Layout windows.  
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A receipt printer will also need to be configured so that if requested by a customer, the Print Receipt option can be 
pressed to produce a physical copy of the receipt. 
 
Go to: Back Office > Setup > Network Printers. 
Drag the receipt printer(s) to the required printer slots for the required POS Terminal(s). 
If required, a printer can be added by pressing the ‘Add’ button on the top-left corner of the window, then configure 
the printer as required.  
After creating the required printer(s), drag the printer entries into the required POS Terminal printer slots below. 
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Before Digital Receipts can be sent to Customers, a Digital Receipt Format must be configured in Idealpos Online. 
Login to Idealpos Online – https://online.idealpos.com.au. 
After logging in, click on the Settings button on the bottom-left corner of the page. 
 

 
 
Within the “Subscriptions” tab, select the Subscription that contains the site with the POS Terminal(s) currently 
being configured. 
 

 
 
Go to the “Receipt Format” tab, then click on the “Add Receipt Format +” button. 
 

 
 
  

https://online.idealpos.com.au/
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This is where the Receipt Format can be customised for your Digital Receipt. 
Name: Enter a Name for this Receipt Format. 
Header Logo Graphic Upload: Upload a graphic that will be displayed in the Header portion of the Digital Receipt. 
Header: Format the Header of your Digital Receipt here. This is where the details about the venue can be entered 
such as the venue name, venue address, venue ABN and any other details that are required in the header portion. 
Footer: Format the Footer of your Digital Receipt here. This is where you may want to list any additional details such 
as trading hours, thank you salutations, Terms and Conditions, refund policies and any other details that should 
appear at the bottom of the receipt in the footer area. 
Footer Logo Graphic Upload: Upload a graphic that will be displayed in the Footer portion of the Digital Receipt. It is 
not compulsory to have a footer graphic, however, you may want to include one if required. 
 
Once the desired Digital Receipt details have been entered, press the ‘Add’ button at the bottom-right corner of the 
window. 
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The newly created Digital Receipt Format will now appear under the list of Receipt Formats. 
The Digital Receipt Format will need to be assigned to the POS Terminals that will use the format. 
Press the assign icon next to the Receipt Format as illustrated below to assign POS Terminals. 
 

 
 
A list of POS Terminals for the selected Subscription will be displayed. 
Enable the checkbox next to each POS Terminal that will use this receipt format > Press ‘OK’. 
 

 
 
The POS IDs will now be listed next to the Digital Receipt Format, indicating that those POS Terminals have been 
successfully linked to the selected Digital Receipt Format. 
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Once the above steps have been completed (Digital Receipts enabled in Global Options, Y/N Option “Prompt to Print 

Receipt” enabled, the Receipt On/Off POS Screen button created, printers configured and Digital Receipt Format 

created), the function is ready for use. 

 

Go to: POS Screen. 

Navigate to the POS Screen tab which contains the Receipt On/Off button and ensure that it shows as ‘RECEIPT IS 

OFF’. 

If the button shows as ‘RECEIPT IS ON’, press the button to toggle receipts so that they are turned off. 

 

 
 

Add items to the sale > ENTER 
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From the Tender screen, select a tender. 
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After selecting a tender, the Digital Receipt prompt is displayed. 

Select the desired option.  

If the option requires the entry of a Mobile Phone Number or Email Address, enter the required information and press 

‘Send’. The receipt will be produced using the selected option. 
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Export Data 

IP-5689 – Impact Data Export – Include Customer Other Codes (User-Defined) 

This function introduces the ability to include Customer Other Codes as part of the Impact Data Export. 

Customer Other Codes are stored in each Customer record within the Other Codes field. 

 

File > Customers > Customers > Select a Customer > Modify. 

The Codes listed in the “Other Codes” field will be included as part of the Customer file that’s exported with the Impact 

Data Export. 
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To enable this function, go to:  

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Import/Export 

Export Folder: Ensure that a path to a valid folder is entered into this field. 

Export Sales Format: Impact Data. 

Sales From: Select All POS Terminals or the required POS Terminal. 

Export Daily at or every minutes: Enter a value into one of these fields for the required interval on when the data is 

required. 
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A User Defined Option will need to be created on the POS Terminal. 

Within the same POS Terminal’s configuration, switch to the POS Settings tab and enter the following User Defined 

Option: 

Description: IMPACTDATAOTHERCODES 

Setting: 1 

 

 
 

Close the POS Terminals window. 

The next time there is a change to one or more Customers, the Exported Customer File (typically named 

[ShopName]_Customers_YYYYMMDDHHMM.txt) will include the Customer’s Other Codes under the “OTHERCODES” 

column header. 

 

The below example shows the OTHERCODES included in the export file. 

Note that the exported data in the below example has been opened as a spreadsheet (exported file extension 

renamed to .csv and opened with a spreadsheet application).  

Also note that several fields have been manually removed to improve the readability of the exported data shown in the 

example below. 
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Kiosk 

IP-5706 – Kiosk v2 – Support for Dine-In/Takeaway Prompt 

This function introduces the ability to display a Dine-In/Takeaway Prompt at the start of each sale on a Kiosk. 

When a sale is started on the Kiosk, the Customer is asked if they want to Dine-In or Takeaway. The selected option is 

recorded against the sale, enabling the venue to identify the Sale Type and any extra preparations that may be 

required based on the option that was chosen (such as preparing the order in takeaway containers, takeaway bag, 

etc.). 

 

The function can be configured by going to: Back Office > Setup > POS Terminals > Select the Kiosk Terminal > 

Modify > Display/Kiosk tab > Enable ‘Dine-In/Takeaway Prompt’. 

 

For further information about configuring this function, refer to the Dine-In/Takeaway Prompt section in the 

Configuring v2 Kiosk topic within the Idealpos User Guide. 

 

 
  

https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm#Dine_In_Takeaway_Prompt
https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm
https://userguide.idealpos.com.au/
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IP-5714 – Kiosk v2 – Support for Order Finalised Image 

This function introduces the ability to display an Order Finalised Image after each sale is finalised on the Kiosk. 

This can be a type of Thank You message with company branding or any other message that needs to be conveyed to 

the customer. 

After the Kiosk order is finalised, the Order Finalised Image is displayed for approximately five seconds, then the Kiosk 

returns to the Home Screen Image. 

 

The function can be configured by going to:  

Back Office > Setup > POS Terminals > Select the Kiosk Terminal > Modify > Display/Kiosk tab.  

Populate the “Order Finalised Image” field with the name of the Order Finalised Image. 

The image should be a JPG file with a size of 1080x1920. 

The Idealpos Demo Database is supplied with a demonstration “Kiosk Thankyou.jpg” image (shown below) which can 

be found in either of the two locations listed below:  

C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\ 

C:\ProgramData\Idealpos Solutions\Idealpos\PicturesDemo\ 

 

The image should be placed in the Pictures folder of each Kiosk, typically:  

C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\ 

 

For further information about configuring this function, refer to the Order Finalised Image section in the Configuring 

v2 Kiosk topic within the Idealpos User Guide. 

 

 
  

https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm#Order_Finalised_Image
https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm
https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm
https://userguide.idealpos.com.au/


 Update History 
Return to top 

Idealpos 8 Build 14 - Update History Page 18 of 26 

 

IP-5715 – Kiosk v2 – Support for Automatic Open/Close Times 

This function introduces the ability to configure the Kiosk to automatically open between specific hours. Outside of the 

configured hours, the Kiosk will display the Kiosk Closed Image and will not accept any input. 

 

This function can be configured by going to: 

Back Office > Setup > POS Terminals > Select the Kiosk Terminal > Modify > Display/Kiosk tab. 

Populate the Open From/To times with the times that the Kiosk should be open. 

The Kiosk Closed Image will also need to be configured so that the Kiosk displays a visual indication that it is closed 

and no input at the Kiosk is accepted. 

Populate the “Kiosk Closed Image” field with the name of the Kiosk Closed Image. 

The image should be a JPG file with a size of 1080x1920. 

The Idealpos Demo Database is supplied with a demonstration “Kiosk Closed.jpg” image (shown below) which can be 

found in either of the two locations listed below: 

C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\ 

C:\ProgramData\Idealpos Solutions\Idealpos\PicturesDemo\ 

 

The image should be placed in the Pictures folder of each Kiosk, typically:  

C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\ 

 

For further information about configuring this function, refer to the Open From/To section in the Configuring v2 Kiosk 

topic within the Idealpos User Guide. 

 

 
  

https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm#Open_From_To
https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm
https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm
https://userguide.idealpos.com.au/
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IP-5716 – Kiosk v2 – Open/Close Function from POS Screen 

This function introduces the ability to Open and Close the Kiosk from the POS Screen of a networked POS Terminal. 

The Open and Close buttons can be created on any required POS Screen Tab.  

Each Open Kiosk/Close Kiosk button can be configured to run the action on all Kiosk Terminals, a range of Kiosk 

Terminals or specific Kiosk Terminal Numbers. 

When the Kiosk is Open, the Kiosk will display the Home Screen Image and will accept orders from customers. 

When the Kiosk is Closed, the Kiosk will display the Kiosk Closed Image and will not accept any touchscreen input. 

 

To configure this function, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons > Select a POS Screen Tab on which the buttons will be created. 

 

Configure two blank buttons as follows: 

 

POS Range: Leave field as blank to Open/Close All Kiosks, enter a range (e.g. 1-3) to close the specified range of Kiosk 

Terminals, or enter individual Kiosk Terminal Numbers (e.g. 1,2,3) to Open/Close the terminal numbers listed. 

 

 
 

 
 

For further information about configuring and using this function, refer to the Kiosk Function – Open/Close section in 

the Configuring v2 Kiosk topic within the Idealpos User Guide. 

  

https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm#Kiosk_Function_Open_Close
https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm
https://userguide.idealpos.com.au/
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IP-5732 – Kiosk v2 – Support for Customer Code Scanning 

This function introduces the ability to enable Customer Code Scanning. 

When enabled and a barcode scanner is configured/connected to the Kiosk, Customers can then scan their loyalty card 

number via the barcode scanner which will add them to the sale, enabling them to accrue points and obtain any 

special promotions that are applicable to them. 

 

To configure this function, go to: Back Office > Setup > POS Terminals > Select the Kiosk Terminal > Modify. 

From the Display/Kiosk tab, enable the option “Code Scanning”. 

 

Depending on the type of Barcode Scanner connected to the Kiosk, you might also need to configure the scanner. 

The Barcode Scanner can be selected in Idealpos via Back Office > Setup > POS Terminals > Modify > Other 

Peripherals > Barcode Scanner > Select the required Type.  

In most cases, the Keyboard Wedge option should suffice. 

 

After the Code Scanning option has been enabled, perform a Close Suite/Open Suite on the Kiosk Terminals. 

The top of the Kiosk screen will display a prompt to the Customer informing them to click and scan their card. 

Based on feedback received from resellers, additional customisability may be offered in future builds of Idealpos. 

 

 
 

After the button is pressed, it will change to a “Scan Card…” prompt… 

 

 
 

After a Card has been scanned, the Customer’s Name will appear at the top of the Kiosk screen with their balance. 

 

 
 

For further information about configuring and using this function, refer to the Code Scanning/Pay by Points section in 

the Configuring v2 Kiosk topic within the Idealpos User Guide. 

  

https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm#Code_Scanning_Pay_by_Points
https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm
https://userguide.idealpos.com.au/
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IP-5733 – Kiosk v2 – Support for Pay by Points 

This function introduces the ability for Customers to pay for their purchases at a Kiosk using points that they’ve 

previously accrued. 

To use this function, the Support for Customer Code Scanning option needs to be configured as outlined in this 

document. 

The “Pay by Points” option appears on the bottom-left corner of the Kiosk screen when a Customer has been added to 

the sale and the Customer presses the ‘View Order’ button. 

 

 
 

If the Finalise Warning has been enabled for the POINTS tender, the Customer will see a finalisation warning after 

pressing the “Pay by Points” button. 

 

 
 

If the Customer has insufficient points and attempts to pay for the sale via the “Pay by Points” button, they will see the 

following prompt, preventing them from finalising the sale with points. 

 

 
 

For further information about configuring and using this function, refer to the Code Scanning/Pay by Points section in 

the Configuring v2 Kiosk topic within the Idealpos User Guide. 

  

https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm#Code_Scanning_Pay_by_Points
https://userguide.idealpos.com.au/Content/Kiosk/Configuring%20Kiosk%20v2.htm
https://userguide.idealpos.com.au/
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Qantum Loyalty Interface 

IP-5639 – Qantum Loyalty Interface 

This function introduces the ability to use Idealpos with the Qantum Loyalty app. 

The Qantum Loyalty Interface is an interface which enables customers to download the Qantum Loyalty app and 

create a new Qantum Loyalty account. 

Once they’ve created their account, they can visit a venue that is using the Qantum Loyalty Interface and present their 

Qanum Loyalty Digital QR Card to accrue points when making purchases, as well as redeeming Special Offers such as 

discounts. Once a Special Offer has been redeemed, the offer will be marked as redeemed and will disappear from 

their app. Once the customer has accrued sufficient points, they can redeem their points in place of paying with cash. 

Points are accrued and redeemed at the rate that is configured on each POS Terminal (configured in Setup > POS 

Terminals > Select POS Terminal > Modify > Miscellaneous Settings > Points per Dollar/Point Redemption Value). 

 

As the process involved in configuring the Qantum Loyalty Interface is lengthy, please refer to the Qantum Loyalty 

Interface topic in the Idealpos User Guide for more information about configuring and using this interface. 

 

  

https://userguide.idealpos.com.au/#Qantum%20Loyalty/Qantum%20Loyalty%20Interface.htm
https://userguide.idealpos.com.au/#Qantum%20Loyalty/Qantum%20Loyalty%20Interface.htm
https://userguide.idealpos.com.au/
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Room Interface 

IP-5738 – Room Interface – GL Code Mapping by Session (User-Defined) 

This function introduces the ability to customise GL Code Mapping by Session via User-Defined options. 

User-Defined options are typically configured in the POS Terminal Settings (Back Office > Setup > POS Terminals > 

Select the POS Terminal > Modify > POS Settings > User-Defined Options). 

 

The below is a list of sample User-Defined Options: 

 

Breakfast = Session 1/Meal Period 1 

FOOD => SESSION1SC1GLCODE => 160-5050-44030-HRF01-000-0001 

BEVERAGE => SESSION1SC2GLCODE => 160-5050-44030-HRF01-000-0001 

GROCERY => SESSION1SC3GLCODE => 160-5050-44030-HRF01-000-0001 

 

Lunch = Session 2/Meal Period 2 

FOOD => SESSION2SC1GLCODE => 160-5050-44030-HRF01-000-0002 

BEVERAGE => SESSION2SC2GLCODE => 160-5050-44030-HRF01-000-0002 

GROCERY => SESSION2SC3GLCODE => 160-5050-44030-HRF01-000-0002 

 

Dinner = Session 3/Meal Period 3 

FOOD => SESSION3SC1GLCODE => 160-5050-44030-HRF01-000-0003 

BEVERAGE => SESSION3SC2GLCODE => 160-5050-44030-HRF01-000-0003 

GROCERY => SESSION3SC3GLCODE => 160-5050-44030-HRF01-000-0003 
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E.g. User-Defined Option: 
“SESSION3SC1GLCODE” = xxxx. 
Where xxxx is the GL Code. 
 
In Back Office > Setup > POS Terminals > Select a Terminal > Modify > POS Settings tab > User-Defined Options: 
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Stock Items 

IP-5752 – Stock Item Search screen – Support for Description 3 in search filter list 

This function introduces the ability to select the Description 3 field from the search filter list. 

When the Description 3 field is selected from the search filter list, Idealpos will search for Stock Items that have a 

Description 3 which matches the term that has been entered in the search field. 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items. 

On the top-left corner of the screen, click on the ‘Code’ option, then select ‘Description 3’ from the list. 

 

 
 

‘Description 3’ will appear above the search field, which indicates that Idealpos will search within the Description 3 field 

of all Stock Items and any Stock Items that match the entered search term will be displayed in the Stock Items grid. 
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This function will search for items that match the Description 3/Long Description shown below. 

 

The label that’s used for the Description 3 field is configurable via Back Office > Setup > Global Options > Other 

Options > Stock Item Descriptions > Description 3.  

In the example below, the Description 3 label has been set as ‘Long Description’ as configured in Global Options. 

 

  


